problema con multiads

Foros Joomla 2.5 Plugins Joomla 2.5 problema con multiads

  • Este debate tiene 4 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 7 años por gymvago.
  • Post
    gymvago
    Participante

    Hola tengo un extraño problema con este plugin. Lo instalado en diferentes joomlas 2.5, y en todos me tira el siguiente error cuanto trato de subir imágenes a los artículos (lo cual no tiene nada que ver con el plugin en sí), sin embargo, en localhost el error no se reproduce:

    Warning: Missing argument 4 for plgContentMultiads::onContentAfterDisplay() in /homepages/40/d316671188/htdocs/mydomain/plugins/content/multiads/multiads.php on line 145

    Warning: Missing argument 4 for plgContentMultiads::onContentBeforeDisplay() in /homepages/40/d316671188/htdocs/mydomain/plugins/content/multiads/multiads.php on line 104

    De que puede ser?
    un saludo

Si te ha servido... ¡ Compartelo en tus Redes Sociales !
Mostrando 3 respuestas a los debates
  • Respuestas
      Federico Piccoli
      Participante

      Posicionar mi web en Google

      Ciao

      Decir que puede ser és tirar a equivocarse, habría que saber a que corresponden las instrucciones de las lineas 104 y 145.

      gymvago
      Participante

      [quote=»Federico Piccoli» post=28585]Ciao

      Decir que puede ser és tirar a equivocarse, habría que saber a que corresponden las instrucciones de las lineas 104 y 145.[/quote]

      Gracias, pero no dicen mucho estas lineas. La verdad es que desde que actualice mi joomla 2.5 desde joomla 1.5, via jupgrade, tengo muchos problemas raros, pero este concretamente, me pasa en todas las webs, por lo que no sé si será algo del hosting, que he mirado, y usa una versión php 5.2, no sé si tendrá algo que ver.

      Esto es lo que ponen esas lineas:

      104 function onContentBeforeDisplay($context, &$article, &$params, $limitstart)

      145 function onContentAfterDisplay($context, &$article, &$params, $limitstart)

      Un saludo.

      Federico Piccoli
      Participante

      Ciao

      No soy un experto de php, pero yo empezaría investigarndo la variable $limitstart que tradicionalmente és conflictiva.

      Si la versión de php és como minimo 5.2.4 está bien

      gymvago
      Participante

      Gracias, tienes razón, por ahí van los tiros.
      He encontrado este tutorial, que además incluye un archivo corregido, pero no dice ni de cuándo es el artículo, ni si se trata de una versión para joomla 1.5 o joomla 2.5, ni tampoco sé si será fiable.

      Tampoco entiendo porque sucede este error, pero acabo de probar el content ads, un programa similar, y éste hace la cuenta de los anuncios como le da la gana. Pongo que solo muestre uno por página, y me los muestra todos. En fin…

      Un saludo. Dejo el enlace:

      http://www.e-opensources.com/web-design/923-how-to-fix-error-of-missing-argument-4-for-plgcontentmultiads-oncontentbeforedisplay

Mostrando 3 respuestas a los debates
  • El foro ‘Plugins Joomla 2.5’ está cerrado y no se permiten nuevos debates ni respuestas.
Si te ha servido... ¡ Compartelo en tus Redes Sociales !