Error 1062 al crear nuevo usuario

Foros Componentes Especiales Virtuemart Error 1062 al crear nuevo usuario

  • Post
    luis56
    Luis
    Participante

    Hola, estoy desconsertado. Actualize mi virtuemart 2 a VM 3 y ahora todo funciona bien, pero cuando quiero hacer una compra, en el paso de registro previa compra para dar de alta el usuario, me salta error 1062.

    Escrito:

    [i]1062
    Se ha producido un error mientras se procesaba su solicitud.

    Si la dificultad persiste, por favor, contacte con el administrador del sistema de este sitio y reporte el error de más abajo.[/i]

    1062 Duplicate entry '4294967295' for key 'PRIMARY' SQL=INSERT INTO `w47fa_virtuemart_userinfos` (`virtuemart_user_id`,`virtuemart_userinfo_id`,`address_type`,`address_type_name`,`name`,`company`,`last_name`,`first_name`,`phone_1`,`phone_2`,`fax`,`address_1`,`address_2`,`city`,`virtuemart_state_id`,`virtuemart_country_id`,`zip`,`created_on`,`created_by`,`modified_on`,`modified_by`,`locked_on`,`locked_by`,`nif_cif`) VALUES ('2981','0','BT','','luis','','suarez','Luis ','','','','C/ los mandriles 28','','Vigo','321','195','23456','2016-02-11 17:06:56','0','2016-02-11 17:06:56','0','0','0','12134567L')

    Y el caso es que el usuario tiene los datos introducidos en la base de datos, pero salta ese error que impide que el usuario pueda seguir comprando.

    Saludos

    0
Si te ha servido... ¡ Compartelo en tus Redes Sociales !
Mostrando 2 respuestas a los debates
  • Respuestas
      redlo
      Moderador Foro
      Participante

      Posicionar mi web en Google

      Hola Luis, esto suele suceder en las migraciones para virtuemart 3. Al menos a mi ya me ha pasado dos veces. Puede dar ese error u otros como el error 167.

      La primera vez que me paso, pregunte en el foro de virtuemart sin solución, solo un apunte de uno de los creadores de virtuemart en el que decia que era poco menos que “extraño”. Bien viendo que no me daban la solución, me puse a indagar y resulta que el último valor insertado era de 4294967295, y claro, el siguiente registro a insertar se salia del rango de tipo de datos int. Los registros de dicha tabla comenzaban bien, con un auto_increment de 1, pero luego algo sucedía para llegar a estos valores.

      Entonces, lo que hice fue cambiar el tipo de datos de INT a BIGINT en la tabla xxx_virtuemart_userinfos.

      En la tabla _virtuemart_userinfos tienes que cambiar el tipo de datos, asi >

      Como esta originalmente
      `virtuemart_userinfo_id` int(1) unsigned NOT NULL AUTO_INCREMENT,

      Y cambiarlo asi, con bigint en vez de int
      `virtuemart_userinfo_id` bigint(1) unsigned NOT NULL AUTO_INCREMENT,

      Enlace de la solución que dí en el foro de virtuemart > Error 167 . Observaras como efectivamente el que me responde es Milbo, uno de los administradores de virtuemart, y como señala que es extraño, pero ya te digo que a mi ya me ha pasado dos veces, y con esta tuya, tres.

      Dime sin con eso lo solucionas. Si no es asi, habra que mirar mas a fondo.

      Saludos

      0
      luis56
      Luis
      Participante

      Hola, lo he probado y ¡¡ FUNCIONA !! Gracias, mil gracias maquina :).

      Para los que no saben como hacer ese cambio, es muy facil. Con Phpmyadmin, hacen una exportación de esa tabla, con DROP TABLE incluido. (Marcar esa opción antes de exportar la tabla)

      Cambian esa linea e importan la tabla remplazando la que teneis ya con bigint.

      De verdad redlo, muchas gracias.

      0
      sergio44
      Sergio
      Participante

      Me salvaste :)… OTRA VEZ. ¿porque los de virtuemart no realizan esta mejora directamente? Y asi evitar este tipo de fallos.

      0
Mostrando 2 respuestas a los debates
  • Debes estar registrado para responder a este debate.
Si te ha servido... ¡ Compartelo en tus Redes Sociales !