Jueves, 22 Noviembre 2018

Problema con HTML, editor JCE

¡ Compartelo en tus REDES SOCIALES ! y siguenos en TWITTER

8 años 9 meses antes
Avatar de eurocohete
eurocohete
Invitado
Invitado
Autor del tema
Problema con HTML, editor JCE #9269
Hola, a ver si alguien me puede ayudar

estoy utilizando el plugin JoomSlide y para hacerlo funcionar requiere que le pongas la clase joomslide a las imagenes, funciona correctamente, pero hay un problema, cuando coloco la clase, al mostrar el articulo en la categoria en blog no me respeta los demas parametros, como por ejemplo el style, los elimina, dentro del editor si se muestran correcamente, alguna sugerencia? pongo el codigo:

<p style="text-align: center;"><strong><img style="margin-right: 10px;" class="joomslide" alt="imagen" src="images/stories/imagen.png" height="171" width="257" /><br /></strong></p>

necesito que me respete el style="margin-right:10px", si no el texto se me pega a la imagen y queda horrible

gracias,

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 9 meses antes
Avatar de redlo
redlo
Administrator
Administrator
Mensajes: 6007
Karma: 321
Más
Problema con HTML, editor JCE #9276
Joomslide es de lo mejorcito que hay para el tratamiento de las imagenes en los contenidos, pero por si te interesa y te resuelve el problema ahi tienes unos cuantos mas (algunos nuevos y actualizados) que puede te resuelvan el problema --> extensions.joomla.org/extensions/photos-...ages/articles-images

Desarrollos Web a medida Joomla
La vida es demasiado corta, como para tomarsela en serio

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 9 meses antes 8 años 9 meses antes por tuxmerlin.
Avatar de tuxmerlin
tuxmerlin
Platinum Boarder
Platinum Boarder
Mensajes: 451
Karma: 42
Más
Problema con HTML, editor JCE #9279
Joomslide funciona con el script archifamoso Highslide.
Cuando usas el plugin y le pones "class="joomslide"" toma los estilos propios que se encuentran en una carpeta del plugin.

Si utilizas permanentemente el "margin-right:10px" te convendría tocar el archivo CSS que te digo.
Entra a "raízJoomla/plugins/content/joomslide/highslide" y busca el archivo "highslide.css" y ponle esto:
.highslide img {
	border: 2px solid silver;
	margin-right:10px;
}

Tux Merlín Extensions
"Orientar personas es despertar vida"... Anselm Grün

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 9 meses antes
Avatar de eurocohete
eurocohete
Invitado
Invitado
Autor del tema
Problema con HTML, editor JCE #9286
Hola! Gracias por las resupuestas, pero sigue sin mantenerme los limites al mostrar en blog en categoria... he probado de poner el margin en varias lineas, pero nada! alguna sugerencia más?

No tendria este problema si el formato en el que muestra las categorias fuese el mismo que el de secciones. No entiendo porque te pone la imagen al principio de todo, antes del titulo y a la izquierda, cuando lo muestro por secciones mantiene el foramto que yo he puesto en el editor...

pues nada eso, a ver si alguien tiene alguna sugerencia más...

Gracias!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 9 meses antes
Avatar de tuxmerlin
tuxmerlin
Platinum Boarder
Platinum Boarder
Mensajes: 451
Karma: 42
Más
Problema con HTML, editor JCE #9287
Está on line la web? cual es?

Tux Merlín Extensions
"Orientar personas es despertar vida"... Anselm Grün

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 9 meses antes
Avatar de eurocohete
eurocohete
Invitado
Invitado
Autor del tema
Problema con HTML, editor JCE #9288
No, todavia la tenemos cerrada, faltan algunos retoques, como por ejemplo este... si quieres te puedo pegar alguna imagen o codigo....

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 9 meses antes
Avatar de tuxmerlin
tuxmerlin
Platinum Boarder
Platinum Boarder
Mensajes: 451
Karma: 42
Más
Problema con HTML, editor JCE #9289
Bueno, una pena, sería más fácil.

Puede ser la maquetación CSS de la plantilla lo que esté causando el problema.

Revisa en template.css y mira si tienes clases referentes al tag de html "img", tal vez alguno de esos te cambia la vista de la imagen.

Tux Merlín Extensions
"Orientar personas es despertar vida"... Anselm Grün

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Temas Relacionados

Asunto temas relacionadosRelevanciaFecha del último post
Problema en editor, codigo html12.13Sábado, 29 Septiembre 2012
Problemas con el editor HTML9.75Sábado, 14 Mayo 2011
problema con html7.79Sábado, 11 Febrero 2012
PROBLEMA AL COLGAR IMAGEN EN -PERSONALIZAR HTML-7.53Miércoles, 29 Septiembre 2010
Problema al insertar un modulo html en joomla 1.7 "[SOLUCIONADO]"7.45Miércoles, 20 Junio 2012
Problema con el editor7.15Jueves, 06 Agosto 2009
Problema con el editor7.15Miércoles, 07 Octubre 2009
problema con jce editor7.15Viernes, 19 Febrero 2010
Problema con editor de Virtuemart7.07Miércoles, 02 Febrero 2011
Problema con el editor de joomla 1.67.07Viernes, 08 Abril 2011
Tiempo de carga de la página: 0.661 segundos