Martes, 22 Enero 2019

K2 no se ven las imágenes en los articulos

¡ Compartelo en tus REDES SOCIALES ! y siguenos en TWITTER

4 años 10 meses antes
Avatar de Tximeleta
Tximeleta
Fresh Boarder
Fresh Boarder
Mensajes: 5
Más
Autor del tema
K2 no se ven las imágenes en los articulos #32196
Un saludo:
Hace muy poco que me he lanzado a usar el componente K2, pues creo que me puede ayudar a hacer la página web con más posibilidades. Uso la plantilla puri III y las ultimas versiones de Joomla 3 y K2.
Cuando he exportado desde joomla a K2 todo ha salido bien a no ser que cuando voy al sitio las imágenes de los artículos no se ven. Cuando abro el articulo desde la administración las imágenes se ven.
He probado con artículos nuevos y pasa lo mismo nos se ven las imágenes.
A la espera de alguna pista
Gracias.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

4 años 10 meses antes 4 años 10 meses antes por redlo.
Avatar de alex99
alex99
Gold Boarder
Gold Boarder
Mensajes: 218
Karma: 17
Más
K2 no se ven las imágenes en los articulos #32197
¿Puedes facilitar la URL de la pagina a en cuestión? .

El componente K2 trabaja con la libreria Mbstring de php y pueden suceder este tipo de errores si no la tienes instalada o activada.

Otras posibilidades son revisar la ruta de esas imagenes y asegurarte que no tienes ningun plugin generador de miniaturas.
El siguiente usuario dijo gracias Tximeleta

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

4 años 9 meses antes 4 años 9 meses antes por Tximeleta.
Avatar de Tximeleta
Tximeleta
Fresh Boarder
Fresh Boarder
Mensajes: 5
Más
Autor del tema
K2 no se ven las imágenes en los articulos #32220
Gracias alex99
He mirado en la configuración del PHP y no aparece la librería que me comentas, tendría que añadir al php algún parámetro? puede ser este?
--enable-mbstring
o tengo que instalar la librería ¿cómo se haría? en esto no tengo mucha idea.
Las pruebas las podría hacer en Xamp
Mi versión de PHP es 5.3.3
La plantilla Puri III
la Web es
diaconos.es
todavía no esta operativa te la abro unos días para que puedas verla
Esta en un servidor virtual que controlo con Parallels panel.
Las imagenes las cojo de las carpetas de image del joomla, las subo y luego las inserto.
yo no he instalado ningún plugin generador de miniaturas
Muchas gracias por tu paciencia de antemano

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

4 años 9 meses antes 4 años 9 meses antes por lorena28.
Avatar de lorena28
lorena28
Moderator
Moderator
Mensajes: 626
Karma: 42
Más
K2 no se ven las imágenes en los articulos #32225
Si, pero primero, limpia el código del texto que no sirve. En esta url > diaconos.es/index.php/item/1309-cual-es-...ente-en-la-iglesiase aprecia que hay código inservible que solo molesta, ya que si comparas con la web de inicio, veras que el modulo k2 tools, se desplaza hacia la parte inferior de tu pagina y es debido a eso mismo.

Luego para activar MBstring, accede al archivo php.ini de tu servidor y comprueba que las referencias al mismo, no estan comentadas. Si lo estuvieran, debes acceder al servidor, activarlo y compilar la version de tu PHP. Luego reiniciar el Apache (Solo para asegurarte) . Si sigue sin funcionar, debes descomentar (Quitar el punto y coma - ; - del principio de la cadena a activar) las referencias a mbstring y reiniciar el Apache y ya tendrias las librerias MBstring activadas.

Y pasate a Easyphp es mucho mas comodo (Al menos para mi) y no te da algunos problemas que surgen con XamPP

Ayuda Joomla!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

4 años 9 meses antes
Avatar de Tximeleta
Tximeleta
Fresh Boarder
Fresh Boarder
Mensajes: 5
Más
Autor del tema
K2 no se ven las imágenes en los articulos #32233
Para limpiar el codigo ¿basta con cambiar el alias del item? yo lo he dejado así pero pasa lo mismo
diaconos.es/index.php/item/1309-1
Lo otro lo voy a intentar
Gracias lorena28

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

4 años 9 meses antes
Avatar de lorena28
lorena28
Moderator
Moderator
Mensajes: 626
Karma: 42
Más
K2 no se ven las imágenes en los articulos #32234
No, para limpiar el codigo que se enconde detras de los textos que has publicado, tienes que acceder al articulo y debes seleccionar TODO el texto y copiarlo a un editor como por ejemplo, el notepad de windows.
Asi consigues eliminar estilos no deseados entre otros.

Vuelves a copiar, esta vez desde notepad de windows, y lo pegas de nuevo al editor joomla, no sin antes eliminar por completo el texto que habia con el código molesto e inservible. Guarda y compruba que el modulo se vuelve a su sitio correcto.
Despues, si tenias palabras de algun color o señeladas en negrita, saltas de texto y demas, lo ajustas desde el mismo editor de joomla.

Con eso bastara para el tema del desplazamiento del módulo.

Ayuda Joomla!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

4 años 9 meses antes
Avatar de Tximeleta
Tximeleta
Fresh Boarder
Fresh Boarder
Mensajes: 5
Más
Autor del tema
K2 no se ven las imágenes en los articulos #32236
Gracias Lorena28.
Osea que son los codigos que arrastramos en el articulo cuando copiamos y pegamos directamente , por ejemplo,.desde una web. Creo que lo he entendido.
Me sigo peleando con lo de mbstring
gracias

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

4 años 9 meses antes
Avatar de lorena28
lorena28
Moderator
Moderator
Mensajes: 626
Karma: 42
Más
K2 no se ven las imágenes en los articulos #32238
Desde una web o desde un Word, asi es, correcto. Otra cosa mas, es el separador de texto de introducción y el texto completo. Lo que se llama el tipico "LEER MÁS" situado bajo el editor.
Si JUSTIFICAS el texto, hazlo por parrafos y no todo el texto, y mas si hay una linea de separación de este tipo, ya que si cierras el parrafo </p> o la division </div> despues de la etiqueta ..
<hr id="system-readmore" />
Sucede que tambien se desmonta todo y ya te puedes volver loc@ hasta dar con la tela ;)

Ayuda Joomla!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

4 años 9 meses antes
Avatar de Tximeleta
Tximeleta
Fresh Boarder
Fresh Boarder
Mensajes: 5
Más
Autor del tema
K2 no se ven las imágenes en los articulos #32239
Gracias
Yo he seguido tu consejo y me he instalado Easyphp y he puesto la página para investigar.
he Encontrado el php.ini
he visto que tiene la libreria esta.
pero luego todo lo que está debajo de
[mbstring]
esta con ; creo que eso lo desactiva te adjunto archivo pdf
Este archivo está oculto a usuarios invitados.
Por favor, inicie sesión o regístrese para verlo.

Tengo que quitar ;?
a la espera

Este mensaje tiene un archivo adjunto.
Por favor iniciar sesión o registrarse para verlo.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Temas Relacionados

Asunto temas relacionadosRelevanciaFecha del último post
imagenes en articulos7Lunes, 28 Marzo 2011
Articulos e imagenes aleatorias6.92Jueves, 31 Diciembre 2009
Problema al insertar imagenes en articulos6.84Martes, 23 Agosto 2011
Alineación texto e imagenes en articulos joomla6.77Viernes, 25 Enero 2013
Añadir artículos desde el frontend - imposible añadir imágenes6Lunes, 19 Enero 2015
GESTOR DE IMAGENES DE JOOMLA NO PREVISUALIZA LAS IMAGENES5.24Lunes, 26 Abril 2010
Traspasar Imagenes a Servidor de Imagenes5.05Lunes, 12 Septiembre 2011
Imagenes en IE 83.76Martes, 01 Marzo 2011
K2 imagenes3.76Martes, 27 Noviembre 2012
K" Imagenes3.76Lunes, 03 Diciembre 2012
Tiempo de carga de la página: 1.641 segundos

Warning: preg_match(): Unknown modifier '/' in /home/solojoomla/public_html/plugins/system/cache/cache.php on line 217