Viernes, 24 Noviembre 2017

Problema al Instalar en Servidor

¡ Compartelo en tus REDES SOCIALES ! y siguenos en TWITTER

8 años 6 meses antes
Avatar de stenver
stenver
Invitado
Invitado
Autor del tema
Problema al Instalar en Servidor #2445
Hola joomleros,

Tengo una web en local que quisiera subir a un servidor, el tema está, que me parece más fácil, instalar Joomla en el servidor, y calcar la web que tengo en local, importando la Base de Datos, el problema está en que al subir los archivos al FTP, empieza la instalación y en el último paso, es decir, justo despues de meter los datos de Servidor, Base de Datos, y todo lo demás, en el paso 7, es decir, justo antes de terminar, me sale un error HTTP 500, sabe alguien que es lo que le pasa??:blink: :blink: :S

Gracias y saludos

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 6 meses antes
Avatar de redlo
redlo
Administrator
Administrator
Mensajes: 5922
Karma: 318
Más
Problema al Instalar en Servidor #2446
Cambia las rutas absolutas de tu archivo configuration.php imagino que sera eso.

Desarrollos Web a medida Joomla
La vida es demasiado corta, como para tomarsela en serio

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 6 meses antes
Avatar de stenver
stenver
Invitado
Invitado
Autor del tema
Problema al Instalar en Servidor #2448
¿Como miro las esa configuración? soy un poco nuevo en esto, porque lo único que he hecho hasta ahora es en local, para ver como iba joomla, las rutas absolutas del archivo configuracion.php donde está? lo modifico al subirlo verdad?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 6 meses antes 8 años 6 meses antes por stenver.
Avatar de stenver
stenver
Invitado
Invitado
Autor del tema
Problema al Instalar en Servidor #2450
Cuando lo hago en Internet Explorer el error que me da es HTTP 500
Cuando lo hago en Mozilla, la información es un poco más amplia, pero igual de confusa para mi

"PHP Warning: file_put_contents(D:\XVRT\midominio.net\Html\Ganaderia\configuration.php) [<a href='function.file-put-contents'>function.file-put-contents</a>]: failed to open stream: Permission denied in D:\XVRT\midominio.net\Html\Ganaderia\installation\installer\models\model.php on line 850 "

Alguna idea?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 6 meses antes
Avatar de Dimar
Dimar
Platinum Boarder
Platinum Boarder
Mensajes: 388
Karma: 28
Más
Problema al Instalar en Servidor #2451
Hola stenver

Ese error es porque esta mal configurado el archivos configuration.php abre ese archivo con un editor (NotePad por ejemplo) y editalo.

Pero mejor aun, te voy a explicar como instalo yo de local a hosting:

1.- Sube (por FTP) todo el contenido de tu proyecto que tienes en local al hosting sin el archivo configuration.php y con la carpeta installation

2.- Respalda toda la base de dato localhost (la que estas utilizando para tu proyecto).

3.- Haz una nueva instalación online desde tu hosting, quiero decir http:// www . TUPAGINA .com/installation

4.- Luego elimina las nuevas tablas en la Base de Dato generadas por la nueva instalación.

5.- Ahora importa la Base de dato (la de localhost), la que previamente le hiciste un respaldo (paso 2).

Ahora bien, recuerda que por haber cambiado la base de dato, debes ingresar a la parte administrativa con los datos que utilizaste en local.

Y listo!!!

De esa manera lo hago yo ;) aunque hay un amigo :lol: que siempre esta recomendando hacer los proyectos desde el hosting, y la verdad es que te puedes encontrar con que no se vean algunas cosas iguales (local - hosting), pero solo es cuestión de editar algunos archivos para que se vea bien desde el hosting. Ademas siempre por local sera mas rápido realizar las paginas.

PD: GGGRRRRRRRRRRRR :angry: No existe algun plugins donde le puedas permitir a usuarios determinados, una duración de la sesión mas largaaaaaaaaaaaaaaaaaa!!! jajajaajajajaaj aunque ya me estoy acostumbrando hacer una copia antes de enviar :P

Exitos!!! ;)

Es mejor enseñar , que dar la solución. ;)

Desde cuando no haces un Backup de tu sitio?? :dry: y que estas esperando?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 6 meses antes
Avatar de stenver
stenver
Invitado
Invitado
Autor del tema
Problema al Instalar en Servidor #2452
En cuanto llegue a casa lo pruebo, gracias.
Ya te cuento

Un saludo

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

8 años 6 meses antes
Avatar de dagget
dagget
Gold Boarder
Gold Boarder
Mensajes: 234
Karma: 60
Más
Problema al Instalar en Servidor #2454
Cuando configuras mal las rutas a los directorios tmp y logs los errores mostrados son otros, yo más bien creo que hay un problema de permisos y se aborta el script cuando file_put_contents intenta escribir los valores de las variables en el configuration.php.

CEO at Joomla! Projects
CEO at GWErp
Linux user number #470399

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Tiempo de carga de la página: 0.204 segundos