Sábado, 15 Diciembre 2018

URL amigables

¡ Compartelo en tus REDES SOCIALES ! y siguenos en TWITTER

7 años 8 meses antes
Avatar de mikado01
mikado01
Invitado
Invitado
Autor del tema
URL amigables #18193
Hola solojoomleros,

Estoy intentando que mi web joomla tenga url amigables, pero no hay manera.

He probado la opción que te viene en joomla y nada.

Me salen errores del tipo 500.

Además pierdo las referencias a la opción sufijo de la clase y las páginas pierden su diseño.

Necesito consejo para poder hacer las url amigables ya que estoy utilizando varios componentes del tipo xmap, virtuemart, k2, facileforms y debó conseguir que todas tengan su url amigable.

Gracias de antemano.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

7 años 8 meses antes
Avatar de redlo
redlo
Administrator
Administrator
Mensajes: 6007
Karma: 321
Más
URL amigables #18199
¿Has renombrado el archivo htaccess.txt como .htaccess (punto htaccess) ? El archivo esta en la raiz de tu joomla.

Desarrollos Web a medida Joomla
La vida es demasiado corta, como para tomarsela en serio

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

7 años 8 meses antes
Avatar de mikado01
mikado01
Invitado
Invitado
Autor del tema
URL amigables #18216
Hola redlo,

Si he renombrado el htaccess.

Gracias por contestar

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

7 años 8 meses antes 7 años 8 meses antes por redlo.
Avatar de redlo
redlo
Administrator
Administrator
Mensajes: 6007
Karma: 321
Más
URL amigables #18217
Edita el archivo .htaccess y busca la cadena de texto --> Options +FollowSymLinks y añades una armuadilla al principio, asi #Options +FollowSymLinks , el problema deberia quedar resuelto. Dependiendo en el servidor que estes y como lo tienen configurado pueden pasar ese tipo de problemas. Pero antes comprueba que las opciones que tienes activadas desde Sitio / Configuracion Global en el cuadro de la derecha "Parámetros de optimización de SEO" estan asi:
  1. URLs amigables para motores de búsqueda
  2. Usar Apache mod_rewrite
En "Agregar el sufijo a las URLs" No, la dejas desactivada.
Ya si siguen los problemas deberias comentarselo a los de tu hosting.

Desarrollos Web a medida Joomla
La vida es demasiado corta, como para tomarsela en serio

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

7 años 8 meses antes 7 años 8 meses antes por mikado01.
Avatar de mikado01
mikado01
Invitado
Invitado
Autor del tema
URL amigables #18233
Hola redlo,

He modificado el .htaccess porque lo demás ya lo estaba haciendo y nada. No funciona ningún link de mi página. Me da este error.

ERROR 500: ERROR INTERNO DEL SERVIDOR
Ha surgido un problema inesperado que impide que el servidor pueda llevar a cabo la solicitud.

Mi .htaccess es el siguiente por si te ayuda:

##
# @version $Id: htaccess.txt 14401 2010-01-26 14:10:00Z louis $
# @package Joomla
# @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
# @license www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

## Can be commented out if causes errors, see notes above.
#Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#<Files ~ "\.xml$">
#Order allow,deny
#Deny from all
#Satisfy all
#</Files>
## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section

Gracias por la respuesta

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

7 años 8 meses antes 7 años 8 meses antes por redlo.
Avatar de redlo
redlo
Administrator
Administrator
Mensajes: 6007
Karma: 321
Más
URL amigables #18235
Haz tres cosas, Purga la cache desde herramientas de joomla, Pulsa CTRL + F5 cuando accedas desde el navegador, si no funciona prueba instalarte este componente que es el que utilizo > www.artio.net/downloads/joomla/joomsef/a...oomsef-3-8-1/details - Tutorial joomsef Y si nada de esto te funciona pregunta a los de tu hosting. Comprueba tambien, desde el admin joomla en Ayuda / Informacion del sistema la version de tu Php, si es 5.3 problemas a la vista, El safe mode debe estar desactivado.
Ah y quitale de nuevo la armoadilla a #Options +FollowSymLinks

Desarrollos Web a medida Joomla
La vida es demasiado corta, como para tomarsela en serio

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

7 años 8 meses antes
Avatar de mikado01
mikado01
Invitado
Invitado
Autor del tema
URL amigables #18255
De momento he conseguido que funcione, del .htaccess que he subido solo le he quitado la almohadilla de RewriteBase /

Lo de las caches también lo había probado, jejeje
Le pegare un vistazo al componente

Gracias por todo

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Temas Relacionados

Asunto temas relacionadosRelevanciaFecha del último post
K2 y las URL amigables5.76Jueves, 02 Julio 2009
URL amigables en Joomla 1.5.X5.69Jueves, 04 Noviembre 2010
No URL amigables con Hostgator5.69Domingo, 20 Febrero 2011
Importancia de las url amigables5.69Lunes, 31 Octubre 2011
Problema con las url amigables5.69Jueves, 14 Febrero 2013
[RTO]Errores de visionado con URL´s amigables5.63Sábado, 07 Febrero 2009
Activar las urls amigables5.63Jueves, 24 Febrero 2011
Problema con URLs amigables5.63Lunes, 06 Febrero 2012
sh404sef o Url amigables con .htaccess?5.63Jueves, 22 Marzo 2012
Problema con urls amigables5.63Jueves, 15 Noviembre 2012
Tiempo de carga de la página: 0.222 segundos

Warning: preg_match(): Unknown modifier '/' in /home/solojoomla/public_html/plugins/system/cache/cache.php on line 217