Jueves, 21 Febrero 2019

No puedo publicar ni editar con el componente MyBlog [RTO]

¡ Compartelo en tus REDES SOCIALES ! y siguenos en TWITTER

9 años 9 meses antes 9 años 9 meses antes por redlo.
Avatar de Dimar
Dimar
Platinum Boarder
Platinum Boarder
Mensajes: 388
Karma: 28
Más
Autor del tema
No puedo publicar ni editar con el componente MyBlog [RTO] #2480
No comprendo.

Hice unas pruebas del componente MyBlog en local con una instalación Joomla de prueba (y funciono bien todo) antes de instalarlo en el proyecto (en local) y ahora no me funciona la opción de publicar ni editar en MyBlog :S

En la configuración de MyBlod en el panel de administración, selecciono todos los permisos (Registrado, Autor, Editor, Publicador, Director, Administrador, Super Administrador) tanto abajo como arriba y luego le doy a guardar, y al volver a la pestaña de permisos veo que estan seleccionados todos, pero cuando voy a editar o publicar en la pagina, no me deja y me dice:

No tienes permisos para enviar ó editar entradas del Blog. Por favor, contacta con el administrador de la web.

Eso me aparece en el editor.

Ni idea de que estará pasando.

Alguien le a pasado???

Exitos!!!! ;)

Es mejor enseñar , que dar la solución. ;)

Desde cuando no haces un Backup de tu sitio?? :dry: y que estas esperando?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

9 años 9 meses antes
Avatar de redlo
redlo
Administrator
Administrator
Mensajes: 6007
Karma: 321
Más
No puedo publicar ni editar con el componente MyBlog [RTO] #2482
Hola dimar, primero gracias por ocuparte de ayudar a cuantos has podido durante mi ausencia. Pregunta: ¿Has instalado algun plugin antes de que te sucediera esto? . Selecciona solo una opcion "Registrado" luego desde una cuenta nueva de registrado intenta editar o crear uno nuevo. cuentame...

Desarrollos Web a medida Joomla
La vida es demasiado corta, como para tomarsela en serio

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

9 años 9 meses antes 9 años 9 meses antes por Dimar.
Avatar de Dimar
Dimar
Platinum Boarder
Platinum Boarder
Mensajes: 388
Karma: 28
Más
Autor del tema
No puedo publicar ni editar con el componente MyBlog [RTO] #2485
Los unicos han sido JomSocial, jomcomment y el sistema de menu.

Hice exactamente lo que me dijiste, pero aun continuo con el problema.

Dale permisos a solo registrados, registrar un nuevo usuario, y ver que sucede.

No comprendo porque pasa eso.

Es como si no guardara los cambios :S

hhaaaaaa!!! y por nada Redlo, es un gusto!!! me imaginaba que estabas algo ocupado, por tu ausencia.

Exitos!!! ;)

Es mejor enseñar , que dar la solución. ;)

Desde cuando no haces un Backup de tu sitio?? :dry: y que estas esperando?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

9 años 9 meses antes
Avatar de Dimar
Dimar
Platinum Boarder
Platinum Boarder
Mensajes: 388
Karma: 28
Más
Autor del tema
No puedo publicar ni editar con el componente MyBlog [RTO] #2486
GGGGGGGGGGRRRRRRRRRRRRRRRRRRRRRR!!!!!!!!!!!

Me molesta cuando soluciono sin saber como :angry: :angry: :angry: :angry: :angry:

lo que hice fue agarrara la base de dato de MyBlog de la otra instalacion y la reemplace por la otra donde tengo el proyecto montado.

:( no me gusta quedarme sin saber cual fue la causa.

Exitos!!! ;)

Es mejor enseñar , que dar la solución. ;)

Desde cuando no haces un Backup de tu sitio?? :dry: y que estas esperando?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

9 años 9 meses antes 9 años 9 meses antes por redlo.
Avatar de redlo
redlo
Administrator
Administrator
Mensajes: 6007
Karma: 321
Más
No puedo publicar ni editar con el componente MyBlog [RTO] #2487
Los componentes de azrul tienen muchos problemas de ese tipo, Jomsocial, Jomcomment etc... No es la primera vez que he tenido que eliminar tablas y reemplazarlas por copias guardadas comprobadas. Al realiar cambios en las configuraciones suele pasar esto. No digo de tocar codigo ni nada de eso, simplemente por decirle que no aparezca un determionado objeto te salta el fallo. La semana pasada un usuario de aqui compro una licencia del Myblog nueva y cuando queria editar un contenido se le quedaba la ventana en blanco, haz memoria lo que te pasaba con el jomsocial algo muy parecido, bueno pues hasta que no le mande una version que tengo guardada no pudo solucionarlo. Al realizar una desinstalacion "SIEMPRE" hay que eliminar manualmente las tablas que quedan en la base de datos, si no lo haces el problema volvera a aparecer.

Desarrollos Web a medida Joomla
La vida es demasiado corta, como para tomarsela en serio

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

9 años 9 meses antes
Avatar de Dimar
Dimar
Platinum Boarder
Platinum Boarder
Mensajes: 388
Karma: 28
Más
Autor del tema
No puedo publicar ni editar con el componente MyBlog [RTO] #2488
Bueno abra que hacer backup de la base de datos muy seguido para no llegar a perder datos.

Gracias Redlo.

Exitos!!! ;)

Es mejor enseñar , que dar la solución. ;)

Desde cuando no haces un Backup de tu sitio?? :dry: y que estas esperando?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

9 años 9 meses antes 9 años 9 meses antes por Dimar.
Avatar de Dimar
Dimar
Platinum Boarder
Platinum Boarder
Mensajes: 388
Karma: 28
Más
Autor del tema
No puedo publicar ni editar con el componente MyBlog [RTO] #2968
Bueno Bueno Bueno!!!!

Me volvio a pasar lo mismo. :angry: asi que decidi buscar que era lo que pasaba, y buscando y buscando en la base de dato me di cuenta de esto:

En mi traduccion del componente MyBlog habia traducido en este archivo: config_template.php

Unas lineas como estas (son varias parecidas):

. ' <option value="Registered"' . $registered . '>- Registered</option>'

(Esa linea es la funcion en el panel de configuracion para dar permisos de redactar en el Blog) Yo en ves de dejarlo como estaba le hice esto:

. ' <option value="Registrado"' . $registered . '>- Registrado</option>'

Entonces cuando hacia cualquier configuracion y guardaba, plasss no me dejaba redactar en Mi blog, puesto que la palabra Registrado la colocaba en la base de dato, y la base de dato la lee como Registered NO como Registrado :laugh: y por ende bloqueaba el acceso a redactar en el blog.

Ahora ya se que tengo que estar pendiente de las traducciones en ese aspecto.

PD: Me encanta encontrar las soluciones :blush: ahora si esta resuelto!!!

Exitos!!! ;)

Es mejor enseñar , que dar la solución. ;)

Desde cuando no haces un Backup de tu sitio?? :dry: y que estas esperando?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Temas Relacionados

Asunto temas relacionadosRelevanciaFecha del último post
Editar MyBlog 3.010.91Miércoles, 03 Junio 2009
Editar/Publicar items k29.92Viernes, 14 Marzo 2014
No puedo hacer nuevos articulos y no puedo editar los antigu9.47Martes, 04 Mayo 2010
¿Cómo puedo instalar la traducción d MyBlog 3 en castellano?9.29Lunes, 07 Junio 2010
No puedo hacer publico los blogs creados con MyBlog9.29Martes, 23 Febrero 2010
Componente Myblog9.01Martes, 01 Junio 2010
Puedo definir que menus publicar con JoomFish?8.54Miércoles, 14 Octubre 2009
No puedo editar algunos articulos de mi web8.32Martes, 01 Febrero 2011
JA Teline IV - No puedo editar la Plantilla.8.32Domingo, 14 Agosto 2011
EasyBook, no puedo borrar ni editar entradas8.23Lunes, 11 Mayo 2009
Tiempo de carga de la página: 0.433 segundos

Warning: preg_match(): Unknown modifier '/' in /home/solojoomla/public_html/plugins/system/cache/cache.php on line 217